What’s Vulnerable › Vulnerabilities
CVE-2021-24637: Fonts Plugin < 3.0.3 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Google Fonts Typography WordPress plugin before 3.0.3 does not escape and sanitise some of its block settings, allowing users with as role as low as Contributor to perform Stored Cross-Site Scripting attacks via blockType (combined with content), align, color, variant and fontID argument of a Gutenberg block.
Affected products
- Fonts Plugin Fonts: before 3.0.3 — fixed in 3.0.3
How to fix
Upgrade to a fixed version: Fonts Plugin Fonts 3.0.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/dd2b3f22-5e8b-41cf-bcb8-d2e673e1d21e
- https://wpscan.com/vulnerability/dd2b3f22-5e8b-41cf-bcb8-d2e673e1d21e
Get alerted when CVE-2021-24637 or the next vulnerability affects your stack