What’s Vulnerable › Vulnerabilities
CVE-2021-24638: OMGF < 4.5.4 - Unauthenticated Path Traversal in REST API
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-22
Description
The OMGF WordPress plugin before 4.5.4 does not escape or validate the handle parameter of the REST API, which allows unauthenticated users to perform path traversal and overwrite arbitrary CSS file with Google Fonts CSS, or download fonts uploaded on Google Fonts website.
Affected products
- OMGF | Host Google Fonts Locally: before 4.5.4 — fixed in 4.5.4
How to fix
Upgrade to a fixed version: OMGF | Host Google Fonts Locally 4.5.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c783a746-f1fe-4d68-9d0a-477de5dbb35c
- https://wpscan.com/vulnerability/c783a746-f1fe-4d68-9d0a-477de5dbb35c
Get alerted when CVE-2021-24638 or the next vulnerability affects your stack