What’s Vulnerable › Vulnerabilities
CVE-2021-24640: Gutenslider < 5.2.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The WordPress Slider Block Gutenslider plugin before 5.2.0 does not escape the minWidth attribute of a Gutenburg block, which could allow users with a role as low as contributor to perform Cross-Site Scripting attacks
Affected products
- WordPress Slider Block Gutenslider: before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: WordPress Slider Block Gutenslider 5.2.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e61dd498-5d0e-45ce-b660-a36c576f8d78
- https://wpscan.com/vulnerability/e61dd498-5d0e-45ce-b660-a36c576f8d78
Get alerted when CVE-2021-24640 or the next vulnerability affects your stack