What’s Vulnerable › Vulnerabilities
CVE-2021-24641: Images to WebP < 1.9 - Multiple Cross Site Request Forgery (CSRF)
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-23 · updated 2026-06-17
- Weakness: CWE-352
Description
The Images to WebP WordPress plugin before 1.9 does not have CSRF checks in place when performing some administrative actions, which could result in modification of plugin settings, Denial-of-Service, as well as arbitrary image conversion
Affected products
- Images to WebP: before 1.9 — fixed in 1.9
How to fix
Upgrade to a fixed version: Images to WebP 1.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/972f8c5d-22b7-42de-a981-2e5acb72297b
- https://wpscan.com/vulnerability/972f8c5d-22b7-42de-a981-2e5acb72297b
Get alerted when CVE-2021-24641 or the next vulnerability affects your stack