What’s Vulnerable › Vulnerabilities
CVE-2021-24645: Booking.com Product Helper < 1.0.2 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Booking.com Product Helper WordPress plugin before 1.0.2 does not sanitize and escape Product Code when creating Product Shortcode, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Booking.com Product Helper: before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: Booking.com Product Helper 1.0.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b15744de-bf56-4e84-9427-b5652d123c15
- https://wpscan.com/vulnerability/b15744de-bf56-4e84-9427-b5652d123c15
Get alerted when CVE-2021-24645 or the next vulnerability affects your stack