What’s Vulnerable › Vulnerabilities
CVE-2021-24648: Registration Magic < 5.0.1.9 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The RegistrationMagic WordPress plugin before 5.0.1.9 does not sanitise and escape the rm_search_value parameter before outputting back in an attribute, leading to a Reflected Cross-Site Scripting
Affected products
- Metagauss RegistrationMagic: before 5.0.1.9 — fixed in 5.0.1.9
How to fix
Upgrade to a fixed version: Metagauss RegistrationMagic 5.0.1.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2646734
- https://wpscan.com/vulnerability/a3573212-2a98-4504-b8f4-b4d46655e17c
- https://plugins.trac.wordpress.org/changeset/2646734
- https://wpscan.com/vulnerability/a3573212-2a98-4504-b8f4-b4d46655e17c
Get alerted when CVE-2021-24648 or the next vulnerability affects your stack