What’s Vulnerable › Vulnerabilities
CVE-2021-24651: Poll Maker < 3.4.2 - Unauthenticated Time Based SQL Injection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-11 · updated 2026-06-17
- Weakness: CWE-89
Description
The Poll Maker WordPress plugin before 3.4.2 allows unauthenticated users to perform SQL injection via the ays_finish_poll AJAX action. While the result is not disclosed in the response, it is possible to use a timing attack to exfiltrate data such as password hash.
Affected products
- Ays Pro Poll Maker: before 3.4.2 — fixed in 3.4.2
How to fix
Upgrade to a fixed version: Ays Pro Poll Maker 3.4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/24f933b0-ad57-4ed3-817d-d637256e2fb1
- https://wpscan.com/vulnerability/24f933b0-ad57-4ed3-817d-d637256e2fb1
Get alerted when CVE-2021-24651 or the next vulnerability affects your stack