What’s Vulnerable › Vulnerabilities
CVE-2021-24652: PostX Gutenberg Blocks for Post Grid < 2.4.10 - Missing Access Controls
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-27 · updated 2026-06-17
- Weakness: CWE-863
Description
The PostX – Gutenberg Blocks for Post Grid WordPress plugin before 2.4.10 performs incorrect checks before allowing any logged in user to perform some ajax based requests, allowing any user to modify, delete or add ultp_options values.
Affected products
- PostX – Gutenberg Blocks for Post Grid: before 2.4.10 — fixed in 2.4.10
How to fix
Upgrade to a fixed version: PostX – Gutenberg Blocks for Post Grid 2.4.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5375bd3e-a30d-4f24-9b17-470b28a8231c
- https://wpscan.com/vulnerability/5375bd3e-a30d-4f24-9b17-470b28a8231c
Get alerted when CVE-2021-24652 or the next vulnerability affects your stack