What’s Vulnerable › Vulnerabilities
CVE-2021-24653: Cookie Bar < 1.8.9 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Cookie Bar WordPress plugin before 1.8.9 doesn't properly sanitise the Cookie Bar Message setting, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Cookie Bar: before 1.8.9 — fixed in 1.8.9
How to fix
Upgrade to a fixed version: Cookie Bar 1.8.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bfa8f46f-d323-4a2d-b875-39cd9b4cee0a
- https://wpscan.com/vulnerability/bfa8f46f-d323-4a2d-b875-39cd9b4cee0a
Get alerted when CVE-2021-24653 or the next vulnerability affects your stack