What’s Vulnerable › Vulnerabilities
CVE-2021-24654: User Registration < 2.0.2 - Low Privilege Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The User Registration WordPress plugin before 2.0.2 does not properly sanitise the user_registration_profile_pic_url value when submitted directly via the user_registration_update_profile_details AJAX action. This could allow any authenticated user, such as subscriber, to perform Stored Cross-Site attacks when their profile is viewed
Affected products
- wpeverest User Registration & Membership – Free & Paid Memberships, Subscriptions, Content Restriction, User Profile, Cu: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: wpeverest User Registration & Membership – Free & Paid Memberships, Subscriptions, Content Restriction, User Profile, Cu 2.0.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5c7a9473-d32e-47d6-9f8e-15b96fe758f2
- https://wpscan.com/vulnerability/5c7a9473-d32e-47d6-9f8e-15b96fe758f2
Get alerted when CVE-2021-24654 or the next vulnerability affects your stack