What’s Vulnerable › Vulnerabilities
CVE-2021-24657: Limit Login Attempts < 4.0.50 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Limit Login Attempts WordPress plugin before 4.0.50 does not escape the IP addresses (which can be controlled by attacker via headers such as X-Forwarded-For) of attempted logins before outputting them in the reports table, leading to an Unauthenticated Stored Cross-Site Scripting issue.
Affected products
- Limit Login Attempts: before 4.0.50 — fixed in 4.0.50
How to fix
Upgrade to a fixed version: Limit Login Attempts 4.0.50. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c789ca04-d88c-4789-8be1-812888f0c8f8
- https://wpscan.com/vulnerability/c789ca04-d88c-4789-8be1-812888f0c8f8
Get alerted when CVE-2021-24657 or the next vulnerability affects your stack