What’s Vulnerable › Vulnerabilities
CVE-2021-24659: PostX Gutenberg Blocks for Post Grid < 2.4.10 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The PostX – Gutenberg Blocks for Post Grid WordPress plugin before 2.4.10 allows users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks via the plugin's block.
Affected products
- PostX – Gutenberg Blocks for Post Grid: before 2.4.10 — fixed in 2.4.10
How to fix
Upgrade to a fixed version: PostX – Gutenberg Blocks for Post Grid 2.4.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5f2fe510-7513-4d33-82d9-3107b3b3f2ae
- https://wpscan.com/vulnerability/5f2fe510-7513-4d33-82d9-3107b3b3f2ae
Get alerted when CVE-2021-24659 or the next vulnerability affects your stack