What’s Vulnerable › Vulnerabilities
CVE-2021-24660: PostX Gutenberg Blocks Saved Templates Addon < 2.4.10 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The PostX – Gutenberg Blocks for Post Grid WordPress plugin before 2.4.10, with Saved Templates Addon enabled, allows users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks via the plugin's shortcode.
Affected products
- PostX – Gutenberg Blocks for Post Grid: before 2.4.10 — fixed in 2.4.10
How to fix
Upgrade to a fixed version: PostX – Gutenberg Blocks for Post Grid 2.4.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/af14ac23-843d-4f80-beaf-237618109edd
- https://wpscan.com/vulnerability/af14ac23-843d-4f80-beaf-237618109edd
Get alerted when CVE-2021-24660 or the next vulnerability affects your stack