What’s Vulnerable › Vulnerabilities
CVE-2021-24661: PostX Gutenberg Blocks Saved Templates Addon < 2.4.10 - Private Content Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-27 · updated 2026-06-17
- Weakness: CWE-200
Description
The PostX – Gutenberg Blocks for Post Grid WordPress plugin before 2.4.10, with Saved Templates Addon enabled, allows users with Contributor roles or higher to read password-protected or private post contents the user is otherwise unable to read, given the post ID.
Affected products
- PostX – Gutenberg Blocks for Post Grid: before 2.4.10 — fixed in 2.4.10
How to fix
Upgrade to a fixed version: PostX – Gutenberg Blocks for Post Grid 2.4.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8d966ff1-9c88-43c7-8f4b-93c88e214677
- https://wpscan.com/vulnerability/8d966ff1-9c88-43c7-8f4b-93c88e214677
Get alerted when CVE-2021-24661 or the next vulnerability affects your stack