What’s Vulnerable › Vulnerabilities
CVE-2021-24666: Podlove Podcast Publisher < 3.5.6 - Unauthenticated SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-27 · updated 2026-06-17
- Weakness: CWE-89
Description
The Podlove Podcast Publisher WordPress plugin before 3.5.6 contains a 'Social & Donations' module (not activated by default), which adds the rest route '/services/contributor/(?P<id>[\d]+), takes an 'id' and 'category' parameters as arguments. Both parameters can be used for the SQLi.
Affected products
- Podlove Podcast Publisher: before 3.5.6 — fixed in 3.5.6
How to fix
Upgrade to a fixed version: Podlove Podcast Publisher 3.5.6. Check the vendor advisory for mitigations.
References
- https://github.com/podlove/podlove-publisher/commit/aa8a343a2e2333b34a422f801adee09b020c6d76
- https://wpscan.com/vulnerability/fb4d7988-60ff-4862-96a1-80b1866336fe
- https://github.com/podlove/podlove-publisher/commit/aa8a343a2e2333b34a422f801adee09b020c6d76
- https://wpscan.com/vulnerability/fb4d7988-60ff-4862-96a1-80b1866336fe
Get alerted when CVE-2021-24666 or the next vulnerability affects your stack