What’s Vulnerable › Vulnerabilities
CVE-2021-24667: Gallery Blocks with Lightbox < 2.2.1- Authenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting vulnerability has been discovered in : Simply Gallery Blocks with Lightbox (Version – 2.2.0 & below). The vulnerability exists in the Lightbox functionality where a user with low privileges is allowed to execute arbitrary script code within the context of the application. This vulnerability is due to insufficient validation of image parameters in meta data.
Affected products
- Gallery Blocks with Lightbox. Image Gallery, (HTML5 video , YouTube, Vimeo) Video Gallery and Lightbox for native galler: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: Gallery Blocks with Lightbox. Image Gallery, (HTML5 video , YouTube, Vimeo) Video Gallery and Lightbox for native galler 2.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5925b263-6d6f-4a03-a98a-620150dff8f7
- https://www.fortiguard.com/zeroday/FG-VD-21-060
- https://wpscan.com/vulnerability/5925b263-6d6f-4a03-a98a-620150dff8f7
- https://www.fortiguard.com/zeroday/FG-VD-21-060
Get alerted when CVE-2021-24667 or the next vulnerability affects your stack