What’s Vulnerable › Vulnerabilities
CVE-2021-24669: MAZ Loader < 1.3.3 - Contributor+ SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-08 · updated 2026-06-17
- Weakness: CWE-89
Description
The MAZ Loader – Preloader Builder for WordPress plugin before 1.3.3 does not validate or escape the loader_id parameter of the mzldr shortcode, which allows users with a role as low as Contributor to perform SQL injection.
Affected products
- MAZ Loader – Preloader Builder for WordPress: before 1.3.3 — fixed in 1.3.3
How to fix
Upgrade to a fixed version: MAZ Loader – Preloader Builder for WordPress 1.3.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b97afbe8-c9ae-40a2-81e5-b1d7a6b31831
- https://wpscan.com/vulnerability/b97afbe8-c9ae-40a2-81e5-b1d7a6b31831
Get alerted when CVE-2021-24669 or the next vulnerability affects your stack