What’s Vulnerable › Vulnerabilities
CVE-2021-24672: One User Avatar < 2.3.7 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The One User Avatar WordPress plugin before 2.3.7 does not escape the link and target attributes of its shortcode, allowing users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks
Affected products
- One User Avatar | User Profile Picture: before 2.3.7 — fixed in 2.3.7
How to fix
Upgrade to a fixed version: One User Avatar | User Profile Picture 2.3.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/762c506a-f57d-450f-99c0-32d750306ddc
- https://wpscan.com/vulnerability/762c506a-f57d-450f-99c0-32d750306ddc
Get alerted when CVE-2021-24672 or the next vulnerability affects your stack