What’s Vulnerable › Vulnerabilities
CVE-2021-24673: Appointment Hour Booking < 1.3.16 - Authenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Appointment Hour Booking WordPress plugin before 1.3.16 does not escape some of the Calendar Form settings, allowing high privilege users to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- codepeople Appointment Hour Booking – Booking Calendar: before 1.3.16 — fixed in 1.3.16
How to fix
Upgrade to a fixed version: codepeople Appointment Hour Booking – Booking Calendar 1.3.16. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/75a67932-d831-4dfb-a70d-a07650eaa755
- https://wpscan.com/vulnerability/75a67932-d831-4dfb-a70d-a07650eaa755
Get alerted when CVE-2021-24673 or the next vulnerability affects your stack