What’s Vulnerable › Vulnerabilities
CVE-2021-24680: WP Travel Engine < 5.3.1 - Editor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Travel Engine WordPress plugin before 5.3.1 does not escape the Description field in the Trip Destination/Activities/Trip Type and Pricing Category pages, allowing users with a role as low as editor to perform Stored Cross-Site Scripting attacks, even when the unfiltered_html capability is disallowed
Affected products
- WP Travel Engine: before 5.3.1 — fixed in 5.3.1
How to fix
Upgrade to a fixed version: WP Travel Engine 5.3.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/30f2a0d5-7959-436c-9860-2535020e82d3
- https://wpscan.com/vulnerability/30f2a0d5-7959-436c-9860-2535020e82d3
Get alerted when CVE-2021-24680 or the next vulnerability affects your stack