What’s Vulnerable › Vulnerabilities
CVE-2021-24684: PDF Light Viewer < 1.4.12 - Authenticated Command Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-78
Description
The WordPress PDF Light Viewer Plugin WordPress plugin before 1.4.12 allows users with Author roles to execute arbitrary OS command on the server via OS Command Injection when invoking Ghostscript.
Affected products
- WordPress PDF Light Viewer Plugin: before 1.4.12 — fixed in 1.4.12
How to fix
Upgrade to a fixed version: WordPress PDF Light Viewer Plugin 1.4.12. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b5295bf9-8cf6-416e-b215-074742a5fc63
- https://wpscan.com/vulnerability/b5295bf9-8cf6-416e-b215-074742a5fc63
Get alerted when CVE-2021-24684 or the next vulnerability affects your stack