What’s Vulnerable › Vulnerabilities
CVE-2021-24685: Flat Preloader < 1.5.4 - CSRF to Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Flat Preloader WordPress plugin before 1.5.4 does not enforce nonce checks when saving its settings, as well as does not sanitise and escape them, which could allow attackers to a make logged in admin change them with a Cross-Site Scripting payload (triggered either in the frontend or backend depending on the payload)
Affected products
- Flat Preloader: before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: Flat Preloader 1.5.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/972ecde8-3d44-4dd9-81e3-643d8737434f
- https://wpscan.com/vulnerability/972ecde8-3d44-4dd9-81e3-643d8737434f
Get alerted when CVE-2021-24685 or the next vulnerability affects your stack