What’s Vulnerable › Vulnerabilities
CVE-2021-24686: SVG Support < 2.3.20 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The SVG Support WordPress plugin before 2.3.20 does not escape the "CSS Class to target" setting before outputting it in an attribute, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- benbodhi SVG Support: before 2.3.20 — fixed in 2.3.20
How to fix
Upgrade to a fixed version: benbodhi SVG Support 2.3.20. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2651929
- https://wpscan.com/vulnerability/38018695-901d-48d9-b39a-7c00df7f0a4b
- https://plugins.trac.wordpress.org/changeset/2651929
- https://wpscan.com/vulnerability/38018695-901d-48d9-b39a-7c00df7f0a4b
Get alerted when CVE-2021-24686 or the next vulnerability affects your stack