What’s Vulnerable › Vulnerabilities
CVE-2021-24687: Modern Events Calendar Lite < 5.22.2 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Modern Events Calendar Lite WordPress plugin before 5.22.2 does not escape some of its settings before outputting them in attributes, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Modern Events Calendar Lite: before 5.22.2 — fixed in 5.22.2
How to fix
Upgrade to a fixed version: Modern Events Calendar Lite 5.22.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/300ba418-63ed-4c03-9031-263742ed522e
- https://wpscan.com/vulnerability/300ba418-63ed-4c03-9031-263742ed522e
Get alerted when CVE-2021-24687 or the next vulnerability affects your stack