What’s Vulnerable › Vulnerabilities
CVE-2021-24702: LearnPress < 4.1.3.1 - Multiple Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The LearnPress WordPress plugin before 4.1.3.1 does not properly sanitize or escape various inputs within course settings, which could allow high privilege users to perform Cross-Site Scripting attacks when the unfiltred_html capability is disallowed
Affected products
- thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses: before 4.1.3.1 — fixed in 4.1.3.1
How to fix
Upgrade to a fixed version: thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses 4.1.3.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/30635cc9-4415-48bb-9c67-ea670ea1b942
- https://wpscan.com/vulnerability/30635cc9-4415-48bb-9c67-ea670ea1b942
Get alerted when CVE-2021-24702 or the next vulnerability affects your stack