What’s Vulnerable › Vulnerabilities
CVE-2021-24707: Learning Courses < 5.0 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Learning Courses WordPress plugin before 5.0 does not sanitise and escape the Email PDT identity token settings, which could allow high privilege users to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Nd-Learning Project Nd-Learning: before 5.0 — fixed in 5.0
How to fix
Upgrade to a fixed version: Nd-Learning Project Nd-Learning 5.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0be5e06e-4ff1-43d2-8ba7-2530519d517e
- https://wpscan.com/vulnerability/0be5e06e-4ff1-43d2-8ba7-2530519d517e
Get alerted when CVE-2021-24707 or the next vulnerability affects your stack