What’s Vulnerable › Vulnerabilities
CVE-2021-2471
- Severity: high (CVSS 7.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-20 · updated 2026-06-17
Description
Vulnerability in the MySQL Connectors product of Oracle MySQL (component: Connector/J). Supported versions that are affected are 8.0.26 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks of this vulnerability can result in unauthorized access to critical data or complete access to all MySQL Connectors accessible data and unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Connectors. CVSS 3.1 Base Score 5.9 (Confidentiality and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:H).
Affected products
- Oracle Communications Cloud Native Core Console: 1.9.0
- Oracle Communications Cloud Native Core Network Slice Selection Function: 1.8.0
- Oracle Communications Cloud Native Core Policy: 1.15.0
- Oracle Communications Cloud Native Core Security Edge Protection Proxy: 1.7.0
- Oracle Mysql Connectors: from 8.0.0 through 8.0.26
- quarkusio quarkus: before 2.2.4; from 2.3.0 before 2.6.0 — fixed in 2.2.4, 2.6.0
How to fix
Upgrade to a fixed version: quarkusio quarkus 2.2.4, 2.6.0. Check the vendor advisory for mitigations.
References
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpuoct2021.html
Get alerted when CVE-2021-2471 or the next vulnerability affects your stack