What’s Vulnerable › Vulnerabilities
CVE-2021-24710: Print-O-Matic < 2.0.3 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Print-O-Matic WordPress plugin before 2.0.3 does not escape some of its settings before outputting them in attribute, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Print-O-Matic: before 2.0.3 — fixed in 2.0.3
How to fix
Upgrade to a fixed version: Print-O-Matic 2.0.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2610060/
- https://wpscan.com/vulnerability/84e83d52-f69a-4de2-80c8-7c1996b30a04
- https://plugins.trac.wordpress.org/changeset/2610060/
- https://wpscan.com/vulnerability/84e83d52-f69a-4de2-80c8-7c1996b30a04
Get alerted when CVE-2021-24710 or the next vulnerability affects your stack