What’s Vulnerable › Vulnerabilities
CVE-2021-24712: Appointment Hour Booking – WordPress Booking Plugin < 1.3.17 - Authenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Appointment Hour Booking WordPress plugin before 1.3.17 does not properly sanitize values used when creating new calendars.
Affected products
- codepeople Appointment Hour Booking – Booking Calendar: before 1.3.17 — fixed in 1.3.17
How to fix
Upgrade to a fixed version: codepeople Appointment Hour Booking – Booking Calendar 1.3.17. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e677e51b-0d3f-44a5-9fcd-c159786b9926
- https://wpscan.com/vulnerability/e677e51b-0d3f-44a5-9fcd-c159786b9926
Get alerted when CVE-2021-24712 or the next vulnerability affects your stack