What’s Vulnerable › Vulnerabilities
CVE-2021-24714: WP All Import < 3.6.3 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Import any XML or CSV File to WordPress plugin before 3.6.3 does not escape the Import's Title and Unique Identifier fields before outputting them in admin pages, which could allow high privilege users to perform Cross-Site attacks even when the unfiltered_html capability is disallowed.
Affected products
- Import any XML or CSV File to WordPress: before 3.6.3 — fixed in 3.6.3
How to fix
Upgrade to a fixed version: Import any XML or CSV File to WordPress 3.6.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a8d314b9-26ac-4b56-a85c-a2528e55e73a
- https://wpscan.com/vulnerability/a8d314b9-26ac-4b56-a85c-a2528e55e73a
Get alerted when CVE-2021-24714 or the next vulnerability affects your stack