What’s Vulnerable › Vulnerabilities
CVE-2021-24715: WP Sitemap Page < 1.7.0 - Admin+ Stored Cross Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Sitemap Page WordPress plugin before 1.7.0 does not properly sanitise and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- WP Sitemap Page: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: WP Sitemap Page 1.7.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/da66d54e-dda8-4aa8-8d27-b8b87100bb21
- https://wpscan.com/vulnerability/da66d54e-dda8-4aa8-8d27-b8b87100bb21
Get alerted when CVE-2021-24715 or the next vulnerability affects your stack