What’s Vulnerable › Vulnerabilities
CVE-2021-24717: AutomatorWP < 1.7.6 - Missing Authorization and Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-863
Description
The AutomatorWP WordPress plugin before 1.7.6 does not perform capability checks which allows users with Subscriber roles to enumerate automations, disclose title of private posts or user emails, call functions, or perform privilege escalation via Ajax actions.
Affected products
- AutomatorWP: before 1.7.6 — fixed in 1.7.6
How to fix
Upgrade to a fixed version: AutomatorWP 1.7.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5916ea42-eb33-463d-8528-2a142805c91f
- https://wpscan.com/vulnerability/5916ea42-eb33-463d-8528-2a142805c91f
Get alerted when CVE-2021-24717 or the next vulnerability affects your stack