What’s Vulnerable › Vulnerabilities
CVE-2021-24718: ARForms Form Builder < 1.5 - Admin+ Stored Cross Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form, Survey & Popup Form Plugin for WordPress plugin before 1.5 does not properly sanitize some of its settings allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Contact Form, Survey & Popup Form Plugin for WordPress – ARForms Form Builder: before 1.5 — fixed in 1.5
How to fix
Upgrade to a fixed version: Contact Form, Survey & Popup Form Plugin for WordPress – ARForms Form Builder 1.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/60c9d78f-ae2c-49e0-aca3-6dce1bd8f697
- https://wpscan.com/vulnerability/60c9d78f-ae2c-49e0-aca3-6dce1bd8f697
Get alerted when CVE-2021-24718 or the next vulnerability affects your stack