What’s Vulnerable › Vulnerabilities
CVE-2021-24720: GeoDirectory < 2.1.1.3 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The GeoDirectory Business Directory WordPress plugin before 2.1.1.3 was vulnerable to Authenticated Stored Cross-Site Scripting (XSS).
Affected products
- paoltaia GeoDirectory – WP Business Directory Plugin and Classified Listings Directory: before 2.1.1.3 — fixed in 2.1.1.3
How to fix
Upgrade to a fixed version: paoltaia GeoDirectory – WP Business Directory Plugin and Classified Listings Directory 2.1.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/BigTiger2020/word-press/blob/main/WrodPress%20Plugin%20GeoDirectory%E2%80%94%E2%80%94Stored%20Cross-Site%20Scripting%20.md
- https://plugins.trac.wordpress.org/changeset/2596452/geodirectory
- https://wpscan.com/vulnerability/9de5cc51-f64c-4475-a0f4-d932dc4364a6
- https://github.com/BigTiger2020/word-press/blob/main/WrodPress%20Plugin%20GeoDirectory%E2%80%94%E2%80%94Stored%20Cross-Site%20Scripting%20.md
- https://plugins.trac.wordpress.org/changeset/2596452/geodirectory
- https://wpscan.com/vulnerability/9de5cc51-f64c-4475-a0f4-d932dc4364a6
Get alerted when CVE-2021-24720 or the next vulnerability affects your stack