What’s Vulnerable › Vulnerabilities
CVE-2021-24722: Restaurant Menu by MotoPress < 2.4.2 - Admin+ Stored Cross Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Restaurant Menu by MotoPress WordPress plugin before 2.4.2 does not properly sanitize or escape inputs when creating new menu items, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Restaurant Menu by MotoPress: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: Restaurant Menu by MotoPress 2.4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/14b29450-2450-4b5f-8630-bb2cbfbd0a83
- https://wpscan.com/vulnerability/14b29450-2450-4b5f-8630-bb2cbfbd0a83
Get alerted when CVE-2021-24722 or the next vulnerability affects your stack