What’s Vulnerable › Vulnerabilities
CVE-2021-24732: Dflip Lite < 1.7.10 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The PDF Flipbook, 3D Flipbook WordPress – DearFlip WordPress plugin before 1.7.10 does not escape the class attribute of its shortcode before outputting it back in an attribute, which could allow users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks
Affected products
- DearHive DearFlip: before 1.7.10 — fixed in 1.7.10
How to fix
Upgrade to a fixed version: DearHive DearFlip 1.7.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9425a9b2-e9b8-41f5-a3ca-623b6da0297c
- https://wpscan.com/vulnerability/9425a9b2-e9b8-41f5-a3ca-623b6da0297c
Get alerted when CVE-2021-24732 or the next vulnerability affects your stack