What’s Vulnerable › Vulnerabilities
CVE-2021-24734: Compact WP Audio Player < 1.9.7 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Compact WP Audio Player WordPress plugin before 1.9.7 does not escape some of its shortcodes attributes, which could allow users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks.
Affected products
- Compact WP Audio Player: before 1.9.7 — fixed in 1.9.7
How to fix
Upgrade to a fixed version: Compact WP Audio Player 1.9.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fb007191-b008-4d19-b896-55fbee2a3cf7
- https://wpscan.com/vulnerability/fb007191-b008-4d19-b896-55fbee2a3cf7
Get alerted when CVE-2021-24734 or the next vulnerability affects your stack