What’s Vulnerable › Vulnerabilities
CVE-2021-24735: Compact WP Audio Player < 1.9.7 - Setting Change via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-352
Description
The Compact WP Audio Player WordPress plugin before 1.9.7 does not implement nonce checks, which could allow attackers to make a logged in admin change the "Disable Simultaneous Play" setting via a CSRF attack.
Affected products
- Compact WP Audio Player: before 1.9.7 — fixed in 1.9.7
How to fix
Upgrade to a fixed version: Compact WP Audio Player 1.9.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/dcbcf6e7-e5b3-498b-9f5e-7896d309441f
- https://wpscan.com/vulnerability/dcbcf6e7-e5b3-498b-9f5e-7896d309441f
Get alerted when CVE-2021-24735 or the next vulnerability affects your stack