What’s Vulnerable › Vulnerabilities
CVE-2021-24738: Logo Carousel < 3.4.2 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Logo Carousel WordPress plugin before 3.4.2 does not validate and escape the "Logo Margin" carousel option, which could allow users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks
Affected products
- Logo Carousel – Logo Slider, Logo Showcase, and Clients Logo Gallery: before 3.4.2 — fixed in 3.4.2
How to fix
Upgrade to a fixed version: Logo Carousel – Logo Slider, Logo Showcase, and Clients Logo Gallery 3.4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2c3d8c21-ecd4-41ba-8183-2ecbd9a3df25
- https://wpscan.com/vulnerability/2c3d8c21-ecd4-41ba-8183-2ecbd9a3df25
Get alerted when CVE-2021-24738 or the next vulnerability affects your stack