What’s Vulnerable › Vulnerabilities
CVE-2021-24740: Tutor LMS < 1.9.9 - Multiple Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Tutor LMS WordPress plugin before 1.9.9 does not escape some of its settings before outputting them in attributes, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 1.9.9 — fixed in 1.9.9
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 1.9.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e6cf694d-c4ae-4b91-97c0-a6bdbafc7d60
- https://wpscan.com/vulnerability/e6cf694d-c4ae-4b91-97c0-a6bdbafc7d60
Get alerted when CVE-2021-24740 or the next vulnerability affects your stack