What’s Vulnerable › Vulnerabilities
CVE-2021-24742: Logo Slider and Showcase < 1.3.37 - Editor Plugin's Settings Update
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-863
Description
The Logo Slider and Showcase WordPress plugin before 1.3.37 allows Editor users to update the plugin's settings via the rtWLSSettings AJAX action because it uses a nonce for authorisation instead of a capability check.
Affected products
- Logo Slider and Showcase: before 1.3.37 — fixed in 1.3.37
How to fix
Upgrade to a fixed version: Logo Slider and Showcase 1.3.37. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8dfc86e4-56a0-4e30-9050-cf3f328ff993
- https://wpscan.com/vulnerability/8dfc86e4-56a0-4e30-9050-cf3f328ff993
Get alerted when CVE-2021-24742 or the next vulnerability affects your stack