What’s Vulnerable › Vulnerabilities
CVE-2021-24747: SEO Booster < 3.8 - Admin+ SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-13 · updated 2026-06-17
- Weakness: CWE-89
Description
The SEO Booster WordPress plugin before 3.8 allows for authenticated SQL injection via the "fn_my_ajaxified_dataloader_ajax" AJAX request as the $_REQUEST['order'][0]['dir'] parameter is not properly escaped leading to blind and error-based SQL injections.
Affected products
- cleverplugins SEO Booster: before 3.8 — fixed in 3.8
How to fix
Upgrade to a fixed version: cleverplugins SEO Booster 3.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2637115
- https://wpscan.com/vulnerability/40849d93-8949-4bd0-b60e-c0330b385fea
- https://plugins.trac.wordpress.org/changeset/2637115
- https://wpscan.com/vulnerability/40849d93-8949-4bd0-b60e-c0330b385fea
Get alerted when CVE-2021-24747 or the next vulnerability affects your stack