What’s Vulnerable › Vulnerabilities
CVE-2021-24751: GenerateBlocks < 1.4.0 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The GenerateBlocks WordPress plugin before 1.4.0 does not validate the generateblocks/container block's tagName attribute, which could allow users with a role as low as contributor to perform Cross-Site Scripting attacks.
Affected products
- GenerateBlocks: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: GenerateBlocks 1.4.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e0131980-d2d3-4780-8a68-a81ee8c90b7a
- https://wpscan.com/vulnerability/e0131980-d2d3-4780-8a68-a81ee8c90b7a
Get alerted when CVE-2021-24751 or the next vulnerability affects your stack