What’s Vulnerable › Vulnerabilities
CVE-2021-24759: PDF.js Viewer < 2.0.2 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The PDF.js Viewer WordPress plugin before 2.0.2 does not escape some of its shortcode and Gutenberg Block attributes, which could allow users with a role as low as Contributor to to perform Cross-Site Scripting attacks
Affected products
- PDF.js Viewer: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: PDF.js Viewer 2.0.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/38274ef2-5100-4669-9544-a42346b6727d
- https://wpscan.com/vulnerability/38274ef2-5100-4669-9544-a42346b6727d
Get alerted when CVE-2021-24759 or the next vulnerability affects your stack