What’s Vulnerable › Vulnerabilities
CVE-2021-24760: Gutenberg PDF Viewer Block < 1.0.1 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gutenberg PDF Viewer Block WordPress plugin before 1.0.1 does not sanitise and escape its block, which could allow users with a role as low as Contributor to perform Cross-Site Scripting attacks.
Affected products
- Gutenberg PDF Viewer Block: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Gutenberg PDF Viewer Block 1.0.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/aebf821f-1724-4e4c-8d42-5a94e509d271
- https://wpscan.com/vulnerability/aebf821f-1724-4e4c-8d42-5a94e509d271
Get alerted when CVE-2021-24760 or the next vulnerability affects your stack