What’s Vulnerable › Vulnerabilities
CVE-2021-24763: Perfect Survey < 1.5.2 - Unauthorised AJAX Call to Stored XSS / Survey Settings Update
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-352
Description
The Perfect Survey WordPress plugin before 1.5.2 does not have proper authorisation nor CSRF checks in the save_global_setting AJAX action, allowing unauthenticated users to edit surveys and modify settings. Given the lack of sanitisation and escaping in the settings, this could also lead to a Stored Cross-Site Scripting issue which will be executed in the context of a user viewing any survey
Affected products
- Perfect Survey: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: Perfect Survey 1.5.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c73c7694-1cee-4f26-a425-9c336adce52b
- https://wpscan.com/vulnerability/c73c7694-1cee-4f26-a425-9c336adce52b
Get alerted when CVE-2021-24763 or the next vulnerability affects your stack