What’s Vulnerable › Vulnerabilities
CVE-2021-24768: WP RSS Aggregator < 4.19.2 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP RSS Aggregator WordPress plugin before 4.19.2 does not properly sanitise and escape the URL to Blacklist field, allowing malicious HTML to be inserted by high privilege users even when the unfiltered_html capability is disallowed, which could lead to Cross-Site Scripting issues.
Affected products
- WP RSS Aggregator – News Feeds, Autoblogging, Youtube Video Feeds and More: before 4.19.2 — fixed in 4.19.2
How to fix
Upgrade to a fixed version: WP RSS Aggregator – News Feeds, Autoblogging, Youtube Video Feeds and More 4.19.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3673e13f-7ce6-4d72-b179-ae4bab55514c
- https://wpscan.com/vulnerability/3673e13f-7ce6-4d72-b179-ae4bab55514c
Get alerted when CVE-2021-24768 or the next vulnerability affects your stack