What’s Vulnerable › Vulnerabilities
CVE-2021-24779: WP Debugging < 2.11.0 - Unauthenticated Plugin's Settings Update
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-862
Description
The WP Debugging WordPress plugin before 2.11.0 has its update_settings() function hooked to admin_init and is missing any authorisation and CSRF checks, as a result, the settings can be updated by unauthenticated users.
Affected products
- WP Debugging: before 2.11.0 — fixed in 2.11.0
How to fix
Upgrade to a fixed version: WP Debugging 2.11.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8d0e65ee-fdd1-4fd6-9a27-01664c703d90
- https://wpscan.com/vulnerability/8d0e65ee-fdd1-4fd6-9a27-01664c703d90
Get alerted when CVE-2021-24779 or the next vulnerability affects your stack