What’s Vulnerable › Vulnerabilities
CVE-2021-24789: Flat Preloader < 1.5.5 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Flat Preloader WordPress plugin before 1.5.5 does not escape some of its settings when outputting them in attribute in the frontend, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed
Affected products
- Flat Preloader: before 1.5.5 — fixed in 1.5.5
How to fix
Upgrade to a fixed version: Flat Preloader 1.5.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e8550ccd-3898-4e27-aca9-ade89823ff4d
- https://wpscan.com/vulnerability/e8550ccd-3898-4e27-aca9-ade89823ff4d
Get alerted when CVE-2021-24789 or the next vulnerability affects your stack