What’s Vulnerable › Vulnerabilities
CVE-2021-24796: My Tickets < 1.8.31 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The My Tickets WordPress plugin before 1.8.31 does not properly sanitise and escape the Email field of booked tickets before outputting it in the Payment admin dashboard, which could allow unauthenticated users to perform Cross-Site Scripting attacks against admins
Affected products
- Joseph C Dolson My Tickets: before 1.8.31 — fixed in 1.8.31
How to fix
Upgrade to a fixed version: Joseph C Dolson My Tickets 1.8.31. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d973dc0f-3cb4-408d-a8b0-01abeb9ef951
- https://wpscan.com/vulnerability/d973dc0f-3cb4-408d-a8b0-01abeb9ef951
Get alerted when CVE-2021-24796 or the next vulnerability affects your stack